Fórmulas básicas para contar no Excel

Contando o número total de células

Para obter o número total de células do intervalo, vazias ou não, utilize a seguinte fórmula. O resultado é obtido com a multiplicação do número de linhas pelo número de colunas. Mas existe a restrição de que os dados do intervalo sejam contíguos, ou seja, no formato de retângulo, não podendo serem selecionados intervalos não contínuos com a tecla Ctrl.

=LINS(Dados)*COLS(Dados)

Contando células em branco

A fórmula abaixo retorna o número de células em branco (vazias) no intervalo de dados. Vale dizer que a função CONTAR.VAZIO também conta células que contém resultados de fórmulas que retornam vazio como resultado. Como por exemplo, quando você retorna “” como resultado de uma verificação da função SE (ex: =SE(A1>3;””;A1)).

=CONTAR.VAZIO(Dados)

Você também pode utilizar a função CONTAR.VAZIO com argumentos de linhas ou colunas inteiras, por exemplo:

=CONTAR.VAZIO(A:A)

Contando células preenchidas

Para contar o número de células preenchidas utilize a função CONT.VALORES passando como parâmetro o intervalo de dados.

=CONT.VALORES(Dados)

A função CONT.VALORES conta células contendo valores, textos, ou valores lógicos como verdadeiro e falso. Assim como resultado de fórmulas que retornam valores vazios.

Contando células contendo números

Para contar apenas células que contém números em um intervalo, utilize a seguinte formula. Observe que células que contém datas são consideradas na contagem, enquanto as células que contém valores lógicos não são.

=CONT.NÚM(Dados)

Contando células que contém texto

Para contar células que contém texto dentro de um intervalo, será necessário utilizar uma fórmula de matriz (lembre que é preciso pressionar Ctrl+Shit+Enter para criar uma fórmula de matriz).

{=SOMA(SE(ÉTEXTO((Dados));1))}

Contando células que não contém texto

A fórmula de matriz abaixo usa a função É.NÃO.TEXTO para contar o número de células que não contém texto no intervalo Dados.

{=SOMA(SE(É.NÃO.TEXTO(Dados);1))}

Contando células que contém valores lógicos

A fórmula de matriz abaixo conta o número de células do intervalo Dados que contém valores lógicos (verdadeiro e falso).

{=SOMA(SE(ÉLÓGICO(Dados);1))}

Contando o número de erros em um intervalo

O Excel disponibiliza três funções para verificar se uma célula contém erros: ÉERROS, ÉERRO, ÉCÉL.VAZIA.

Você pode usar estas funções em uma fórmula de matriz para contar o número de erros em um intervalo. A seguinte fórmula de matriz, por exemplo, retorna o número de erros no intervalo Dados.

=SOMA(SE(ÉERROS(Dados);1))

Caso você queira contar o número de erros específicos, você pode utilizar a função CONT.SE como no exemplo abaixo.

=CONT.SE(Dados; “#DIV/0!”)





Eryx Guimarães

Eryx Guimarães desenvolve e mantém soluções para empreendimentos na web.

Entre em Contato

Contato